Helton Hearing Care | 406-586-0914

Serving Montana With 3 Great Locations

(406) 586-0914

“ Our mission is to enhance the quality of life and sense of well-being of our valued clients and their families by providing exceptional, reliable and ethical hearing healthcare while exceeding the client's expectations of satisfaction at every level.”

Starkey Halo & TruLink

Starkey Hearing Aids

Life is better with Halo, the breakthrough hearing aid engineered to connect directly to your client's iPhone®, iPad®, iPod touch®, and Apple Watch via our easy-to-use TruLink app. The ideal hearing solution for today's more mobile and plugged-in client — Halo and TruLink deliver new standards of performance and personalization, while providing convenient control and effortless connectivity to the things they care about most.

  • Stream calls from your Apple or Android device directly to your hearing aids using Bluetooth® 4.0 wireless technology.
  • Deliver pristine sound and exceptional listening clarity
  • Help you hear comfortably in noise
  • Eliminate buzzing and whistling
  • Stream FaceTime®, music and more directly to your hearing aids

Fulfilling All Your Needs

Download Brochure for more information!

Halo and the TruLink app are compatible with the following Apple devices: iPhone 6 Plus, iPhone 6, iPhone 5s, iPhone 5c, iPhone 5, iPhone 4s, iPad Air 2, iPad Air, iPad (4th generation), iPad mini 3, iPad mini with Retina display, iPad mini, iPod touch (5th generation) and Apple Watch. Use of Apple Watch requires iPhone 5 or later.
Halo and the TruLink app are compatible with iOS 8.3, 8.2, 8.1.3, 8.1.2, 8.1.1, 8.1, 8, 7.1.2, 7.1.1 and 7.1.
Users of the iPhone 5 and iPod touch may experience some occasional minor audible artifacts when streaming audio with any 8.x version of iOS.
You may need to re-pair your hearing aids to your iOS device after you update iOS.
Halo Hearing Aids and the TruLink app are compatible with the following Android products: Samsung Galaxy S6, Samsung Galaxy S5, Samsung Galaxy S4, Samsung Galaxy Note 4, Samsung Galaxy Note 3, HTC One M8 and HTC One M7. It is recommended that Android users use operating system 4.4.4 for Galaxy S5 and S4 phones and operating system 5.0 for Galaxy S6, HTC One M8 and M7 and Note 4 and Note 3. We are constantly evaluating Android products and their compatibility with Halo. Due to the complex nature of the Android platform and many different types of products utilizing this platform, we test each product separately and will provide compatibility information as we complete our rigorous testing. Remember to check this page for updated Android compatibility information.